Installation of Docker Toolbox on Mac: Error loading driver "virtualbox": dial tcp: missing address

When installing 1.9b of the docker toolbox on mac (10.10.5), installation completes correctly but when first starting Docker Quickstart Terminal I get the following message and it seems the default docker vm is not created:

bash --login ‘/Applications/Docker/Docker Quickstart Terminal.app/Contents/Resources/Scripts/start.sh’

Creating Machine default…
Error loading driver “virtualbox”: dial tcp: missing address
Host “default” does not exist
Starting machine default…
Could not load host “default”: Loading host from store failed: Host does not exist: "default"
Setting environment variables for machine default…

.

## ## ==

## ## ## ## ===

/"""""""""""""""""_/ ===
~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ / ===- ~~~
_
___ o /
\ \ /
_
_
_____/

Could not load host “default”: Loading host from store failed: Host does not exist: "default"
docker is configured to use the default machine with IP
For help getting started, check out the docs at https://docs.docker.com

Host “default” does not exist

open for any help!
Thanks!

I’m getting a similar error on my mac:

Machine default already exists in VirtualBox.
Error trying to get host "default": Error attempting to invoke binary for plugin: dial tcp: missing address
Starting machine default...
Could not load host "default": Error attempting to invoke binary for plugin: dial tcp: missing address
Setting environment variables for machine default...

related error from kitematic:

/usr/local/bin/docker-machine -D create -d virtualbox --virtualbox-memory 2048 default returned non zero exit code. Stderr: Docker Machine Version: 0.5.0 (04cfa58) Found binary path at /usr/local/bin/docker-machine-driver-virtualbox Launching plugin server for driver virtualbox Plugin server listening at address Error loading driver "virtualbox": dial tcp: missing address

Here’s what worked for me:

If you don’t have kitematic, install it ( brew install kitematic )

  1. Go to Virtualbox Preferences => Network => Host Only Networks and delete both vboxnet0 and vboxnet1 (ref https://github.com/boot2docker/boot2docker/issues/606#issuecomment-62437837)
  2. I just deleted the VM as well to be thorough
  3. Start Kitematic with finder/spotlight (it’ll automatically start creating the default VM)
  4. docker-machine regenerate-certs default && eval "$(docker-machine env default)"

The eval command will set the environmental variables to their updated values following the certs regen.

Didn’t work for me.

Kitematic already installed.
removed host only adapters
removed default vm
ran Kitematic

received:
/usr/local/bin/docker-machine -D create -d virtualbox --virtualbox-memory 2048 default returned non zero exit code. Stderr: Docker Machine Version: 0.5.0 (04cfa58) Found binary path at /usr/local/bin/docker-machine-driver-virtualbox Launching plugin server for driver virtualbox Plugin server listening at address Error loading driver “virtualbox”: dial tcp: missing address

ran recert command from command line
received:
Regenerating TLS certificates
Could not load host “default”: Error attempting to invoke binary for plugin: dial tcp: missing address

Doesn’t seem to fix the issue quite yet…

If I run the following from the command line, the machine gets created but i have to run it this way every time and Kitematic still doesn’t work…
DYLD_INSERT_LIBRARIES= /Applications/Docker/Docker\ Quickstart\ Terminal.app/Contents/Resources/Scripts/start.sh

Thanks for the suggestion.