Installing Docker Desktop, Windows 11 22H2

After installing Docker Desktop, Windows 11 22H2 doesn’t boot.

When I click on “Close and Restart” after installing Docker Desktop, the system restarts, but Windows doesn’t load (black screen). I’ve tried installing different versions of Docker Desktop, and the issue persists in all cases. I suspect the problem is related to the installation of WSL 2. I tried installing WSL 2 separately, but the result is the same.

I separately enabled:

  • Hyper-V
  • Virtual Machine Platform
  • Windows Subsystem for Linux - turned on separately

However, the result remains the same—reboot, access to the startup screen (BIOS), and then a black screen. I’ve revived the system through Safe Mode and rollback of changes. How can I resolve this issue?

Even if we can give you some ideas to fix it, this sounds like a bug that you could report on GitHub

on the other hand, Docker uses WSL2 in your case so as you also suspected, it could be a WSL2 issue but I have no idea how you could reproduce it without Docker to confirm it.

Have you checked Windows event logs to find some clues why it couldn’t start?

Did you enable auto start in Docker Desktop so it starts when you log in?

Did you also enable virtualization in BIOS?

https://docs.docker.com/desktop/install/windows-install/#system-requirements

  • Enable hardware virtualization in BIOS. For more information, see Virtualization.