Docker Community Forums

Share and learn in the Docker community.

Installing Docker Toolbox on Windows 7 - Authentication Required Error

Guys,

I have downloaded the latest version of Docker (DockerToolbox-19.03.1.exe) and have installed it on my windows 7 (64-bit) machine.

On running the “Docker Quickstart Terminal”, I get the standard message
"docker is configured to use the default machine with IP xx.xx.xx.xx

If I now run the command - “docker info”, it displays the information,

$ docker info
Client:
Debug Mode: false

Server:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 19.03.1
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk s
yslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 894b81a4b802e4eb2a91d1ce216b8817763c29fb
runc version: 425e105d5a03fabd737a126ad93d62a9eeede87f
init version: fec3683
Security Options:
seccomp
Profile: default
Kernel Version: 4.14.134-boot2docker
Operating System: Boot2Docker 19.03.1 (TCL 10.1)
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 989.5MiB
Name: default
ID: KYN7:ZQRZ:UYNC:ULNN:VHUI:ZZMA:HWE4:52ES:UYTM:SZV5:DL6V:O6RJ
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode: false
HTTP Proxy: http://xxxxx:xxxxx@www-proxy.xx.yy.zz.aa:8080
HTTPS Proxy: http://xxxxx:xxxxx@www-proxy.xx.yy.zz.aa:8080
Registry: :index.docker.io/v1/
Labels:
provider=virtualbox
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Product License: Community Engine

If I run the ‘docker-machine ls’ command, I get the following

$ docker-machine ls
NAME ACTIVE DRIVER STATE URL SWARM DO
CKER ERRORS
default * virtualbox Running tcp://xx.xx.xx.xx:2376 v1
9.03.1

Finally, when I run the “docker login” command, it fails with “Authentication Required” error.

$ docker login
Login with your Docker ID to push and pull images from Docker Hub. If you don’t
have a Docker ID, head over to xxxx.xx.xx to create one.
Username: samasca
Password:

Error response from daemon: Get registry - 1 . docker. io / v2 /: authentication
> required

Even though I have provided the proxy settings (including the hostname / port / username and password) details in the windows environment configuration, and additionally provided the details once again in the “start.sh” file, and further once again provided these proxy settings in the config.json file, even then I am still getting the same “Authentication Required” error.

Further, I tried to execute the “docker-compose” command, and once again noted the same “Authentication Required” error.

$ docker-compose -f D:\Apps\Eventuate\Samples\eventuate-examples-java-custo
mers-and-orders-master\docker-compose-eventuate-local-mysql.yml up -d
Pulling zookeeper (eventuateio/eventuate-zookeeper:0.4.0.RELEASE)…

ERROR: Get registry - 1 . docker. io / v2 /: authenticationrequired

Please advise.

Cheers,
Savio