Docker Community Forums

Share and learn in the Docker community.

Invalid registry endpoint - cannot do push to private registry


(Bosanac) #1

Hi,

I run a locked down (no external traffic in our out) network in which I have a docker registry server and two docker agents.

Trying to push to my registry and getting following error;

[root@server1 sysconfig]# docker push cdiregistry.test.test.test:5000/rhel7
Error response from daemon: invalid registry endpoint cdiregistry.test.test.test:5000/v0/: unable to ping registry endpoint cdiregistry.test.test.test:5000/v0/
v2 ping attempt failed with error: Get cdiregistry.test.test.test:5000/v2/: EOF
v1 ping attempt failed with error: Get cdiregistry.test.test.test:5000/v1/_ping: EOF. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add --insecure-registry cdiregistry.test.test.test:5000 to the daemon’s arguments. In the case of HTTPS, if you have access to the registry’s CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d/cdiregistry.test.test.test:5000/ca.crt

Having created a local registry user account, I get following error when trying to do a locker login;

[root@server1 sysconfig]# docker login cdiregistry.test.test.test
Username: username
Password:
Email:
Error response from daemon: invalid registry endpoint cdiregistry.test.test.test/v0/: unable to ping registry endpoint cdiregistry.test.test.test/v0/
v2 ping attempt failed with error: Get cdiregistry.test.test.test/v2/: dial tcp 19.16.13.2:4: connection refused
v1 ping attempt failed with error: Get cdiregistry.test.test.test/v1/_ping: dial tcp 19.16.13.2:4: connection refused. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add --insecure-registry cdiregistry.test.test.test to the daemon’s arguments. In the case of HTTPS, if you have access to the registry’s CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d/ccdiregistry.test.test.test/ca.crt

Have attempted following with no luck ; http://stackoverflow.com/questions/26926749/docker-unable-to-push-image-to-private-registry along with a few other things with no luck.

I am thinking it has something to do with 'Authentication Options’ , as my registry server is unable to ‘dial home’ and verify un and pw.

"Authentication options

standalone: boolean, run the server in stand-alone mode. This means that the Index service on index.docker.io will not be used for anything. This implies disable_token_auth.

index_endpoint: string, configures the hostname of the Index endpoint. This is used to verify passwords of users that log in. It defaults to https://index.docker.io. You should probably leave this to its default.

disable_token_auth: boolean, disable checking of tokens with the Docker index. You should provide your own method of authentication (such as Basic auth)."

Is there a setting or way to get the registry to either 1) disable all authentication or 2) simply work off the username and password created initially on the registry via docker login localhost:8080

Really keen to see a solution, would greatly appreciate assistance.

Thanks, bosanac