Docker Community Forums

Share and learn in the Docker community.

--isolation=hyperv tag in docker compose file


(Daniel1801) #1

Hi everyone, I am using Windows server 17.09 version, with cmd only.
When I using docker-compose up, I am getting the following error:

container 2018c6c90c5e667157d4ede0fa3eb330b14840bc097bad478dde7ad8c0c7b91d encountered an error during CreateContainer: failure in a Windows system call: The operating system of the container does not match the operating system of the host

This error occur because of the hyper-v problem, so running the containers with the following command works:
docker run -it -d -p 2222:80 --isolation=hyperv packagelocatorservice

Is there any option to include this tag in my docker compose file?

this is my docker-compose.yml file

services:

web:
image: web
ports:
- 1444:80
build:
context: …/Packages/web/webapi
dockerfile: Dockerfile

uimetadataservice:
image: uimetadataservice
ports:
- 3882:80
build:
context: ./MetaDataService
dockerfile: Dockerfile

packagelocatorservice:
image: packagelocatorservice
ports:
- 2222:80
build:
context: ./PackageLocatorService/PackageLocatorService
dockerfile: Dockerfile

assetmanagementserviceweb:
image: assetmanagementserviceweb
ports:
- 7555:80
build:
context: ./InfrastructureWebService
dockerfile: Dockerfile

thanks


(Veepee78) #2

I solved this by adding isolation parameter to dockerd service path. Of course not as neat as it would be in compose file…