Docker Community Forums

Share and learn in the Docker community.

Keep getting "You have reached your pull rate limit"

Hi

I keep getting “You have reached your pull rate limit” inside Watchtower, also over 6 hours after, so i don’t get 200 new pulls.

Where inside Docker on a Synology, do I point on my account? I can’t find any place to let it know it’s me, if that is the problem about the account authentication.

I have only 14 containers running, and it just keep spamming me with the “Pull rate limit”.

Can someone help/guide me ?

Hi,

Keep getting the same error message on docker Synology as well :-/ Any thoughts on how to troubleshoot this issue?

Regards,

Hi Richy78
Since I have not heard anything here and since you probably would like to become a paying member to get help with “PULL LIMIT”, I looked at it myself.
For my part, I know that Watchtower is the problem as it pulls updates every ~ 5 minutes.
When I had 20 images, I thought, 6 hours = 60 minutes per. hour, it’s 360 minutes where I can pull 200 pulls.
So if I know that 360minutes = 21600 seconds and I have 20 images = 432000 this I divide by the 200 pulls = 2160 seconds.
So for every 2160 seconds, I can draw an image, without getting beyond the 200 moves within 6 hours.
So I deleted Watchtower and reinstalled it with the following parameter.

sudo docker run --name="watchtower" -d --restart=always -v /var/run/docker.sock:/var/run/docker.sock containrrr/watchtower --stop-timeout 2160s --interval 21600

It works for me, I do not get in “pull limit error” anymore and can even pull some new installations if I have something else I want to install.

I do not know if this is the best way to do it, but it works for me.

Thanks Thomas, I’ll try that and keep you posted. But looks like that you’re the only one who investigates that issue

@thomaspetersen
Your workaround worked for me, Thanks again

cool glad I could help