Docker Community Forums

Share and learn in the Docker community.

Latest failed docker update makes Hyper V unable to create virtual ethernet switch 0x80041002


(Ekfliu) #1

After all the windows meltdown and spectre updates this morning I got an update request from docker for windows. I attempted to update to the latest stable version but instead I got some permission errors and it left my machine without docker installed. So I went and downloaded the latest stable docker for windows and attempts to reinstall. This time install went fine however it thrown an error during startup saying Hyper V was not enabled for some reason and it ask me if I want to auto enable it and reboot. So I did but this time it is now saying Hyper V cannot find network switch DockerNAT. I went into Hyper V manager and attempts to create a virtual ethernet switch as a test and no matter what kind of virtual switch it is it always return a Not found 0x80041002.

I google the error and try all of different things but none of them actually worked. All of them still resulted in the Not found 0x80041002. This include disable and enable hyper v feature in the Windows feature on off. Going to device manager and remove all hyper v network switches. Going to network settings making sure no hyper v virtual network present. Uninstall cisco any connect vpn. Uninstall oracle virtual box. running netcfg -d and reinstalling ethernet driver and disable and re-enable hyper v features. Uninstall and reinstall docker for windows. But none of these things worked. Anyone face the same issues and have it working again without reinstalling the entire os?


(Ekfliu) #2

I was able to fix this issue by going to windows feature and removing hyper v and container. You must remove container feature not just the hyper v. After re-enable both features should work.


(Jaywryan) #3

This fixed my issue as well! Thank you, I was beating my head against a wall…


(Toasterlint) #4

Uhhhg, after a few hours of troubleshooting came across this and this fixed my issue as well… didn’t notice Container was a separate feature from Hyper-V