Localhost mapping fails

Expected behavior

Start docker with enabled localhost forwarding/proxy works

Actual behavior

it doesnt



Steps to reproduce the behavior

started latest (todays) update of docker 4 win.
enabled localhost mapping.
fails to start.

Thank you for your feedback @vittel

In the log file you sent, it seems you tried to share a z drive but you or something cancelled the authentication prompt and then apply all changes. It’s difficult to understand if where the problem came from the failed drive share or the localhost port mapping action.

To help separate the issue, it would be easier to have a single action in the log file.
One way of achieving this is to follow this :

  • Could you try, setting the localhost port mapping on again,check that Docker is running properly, Then close the app.
  • Restart it again then Check the localhost port mapping, and see if it runs properly and send the latest log file to us.


i would love to do so, but the settings interface doesnt enable the “apply” button anymore when i enable the expose to localhost checkbox -.-

Ive done a complete reset to factory defaults, then activated the expose and pressed apply. same error!
Deactivate the setting, press apply. error is gone.

just the paste of the log after the reset:

Hey thanks for all the efforts here.

I can’t find the error message in the log file you sent, it sounds like moby started successfully.

I suspect you imply the message is “docker does not start” but i’m not sure.

What is the error message you get ?

it is a possible duplicate for this:

the same error is in my last log. Search for “Integration” and you will see it :slight_smile:

Well in your case, it sounds like Docker is running at the end.
Eventhough we try to stop some processes in between, this is not an error which stops the app.

Sounds like you can probably run docker info for instance.

Can you try it ?

Hi @vittel, a new update has been released just now. Can you try this new version?