Docker Community Forums

Share and learn in the Docker community.

No_proxy no longer working in Mac 17.12.0

docker

(Murphye) #1

If you run “docker run -it alpine env” you will see that no_proxy is not being passed in as an environment variable using the latest Docker 17.12.0. If I downgrade to 17.9.0, I see that’s being passed in.

This seems to be a defect and is preventing me from running OpenShift on my Mac. This is a blocker for anyone that depends on no_proxy.

Running 10.13.2

Thanks!


(Andyakins) #2

I am seeing this problem too. Haven’t tried downgrading yet - but . since upgrading Docker is ignoring the Bypass Proxy configuration (or seems to be) which has totally broken my pipeline.

– Andy


(Murphye) #3

FYI, you can download older versions from the Release Notes.


(Murphye) #4

Can someone from Docker verify this defect? Is there a way to submit a formal defect?

Thanks,
Eric


(Jasonredhat) #5

FYI - your problem sounds like these issues being tracked:



(Allen Vailliencourt) #6

@andyakins and @murphye - so found this thread today. There is nothing out except this thread that I have found.

So Docker version 17.12 and even latest edge - 18.02 - totally break any local oc cluster up commands.

I had to downgrade to 17.09 in order for it to work as it always has been working. With 17.12 you can manually put in your CLI the following --http-proxy= and --https-proxy= the internal Docker (in my case, OSX) proxy but the --no-proxy= option is completely broken. Even if you add it to the Docker preferences.

Very frustrating as this has taken me a good bit to dig around to figure out what is going on. Glad I found this thread.


(Jchen86) #7

Same issue here. I’m on Docker 17.12, and the --no-proxy option is not working for me.

Related issues on GitHub:

Looks like the only workaround now is to downgrade Docker to a version prior to 17.12.0.