Docker Community Forums

Share and learn in the Docker community.

Need help installing windows feature using servercore

I am currently trying to install ServerMediaFoundation in docker which is using the WindowsServerCore image. I understand that installing this feature requires a , which cannot be done in a container so I have added a reset script.

If I run the code without the reset script, everything is good and get no errors, however if I run the reset script I get problems.

I am new to this and am still learning so any help would be great, thanks for your time…

I am using the following:


FROM microsoft/windowsservercore
SHELL ["powershell"]
COPY reset.ps1 .
RUN ./reset.ps1
RUN Install-WindowsFeature Server-Media-Foundation;


$mfp = Get-ChildItem -Path (Join-Path    
$env:windir '\servicing\Packages\') -Filter '*Media*.mum';
foreach ($file in $mfp) { 
Write-Host $file.FullName;
(Get-Content $file.FullName).replace(' restart="required"', 'no') | Set-Content $file.FullName;
}; exit 0

Everything seems to run fine until I get to the “Install Server-Media-Foundation” line and then I get an error :

The request to add or remove features on the specified server failed.
name ServerMediaFoundation is unknown. Error: 0x800f0900

Running into the same problem on and

Can anyone help?