Docker Community Forums

Share and learn in the Docker community.

Network non-functional directly after soft reboot

Raspberry Pi Forum Post: Network non-functional directly after soft reboot

I am having issues after a reboot (sudo reboot), the network does not come back online. The only way to resolve this is by unplugging and reinserting the ethernet cable.

I recently posted on the Raspberry Pi Forums and after some testing, it was suggested that it appears there is conflict between the host and docker.

I did try adding denyinterfaces veth* to the beginning of /etc/dhcpcd.conf but did not work.

The last post suggested issues with docker firewall config issues. Anyone know how I test and fix these issues?

Expected Results: When rebooting, the network recovers and do not need to unplug + reinsert the ethernet cable.

I have been investigating this further and after extensive testing, it appears my issue is isolated to the bridge network / containers. I removed the bridge containers, kept the host ones and the Pi seems to successfully boot every time.

Anyone know how I go about fixing the bridge ones?

At first, I though it must be a subnet clashing but I have changed the default subnet a couple of times now and the issue is still persistent.

Here is my compose file

I also tried a few commands to try and reset the network adapters when the system failed to start with no luck. Commands used
sudo ifdown eth0
sudo ifup eth0 (also tried docker0)

service networking restart

sudo ifconfig eth0
down sudo ifconfig eth0 up