Network: Win + Linux container

Hello community,
I am running on a Win 11 PRO machine the Docker engine and I am using WSL2 to run the Linux containers (on the Linux engine).
Can you please help me with the mandatory steps to have a Win IIS container connected to a mysql linux container?
I have created the swarm using the win engine as master and joined by the linux engine (still same machine).
I have created an overlay network and the network is visible from both the instances. The Linux mysql container runs ok, when I try to run the IIS windows container I get this error:

“Error response from daemon: attaching to network failed, make sure your network options are correct and check manager logs: context deadline exceeded.”

Can you help please?
Thank you.
Lucio

Have you done what the error message said? “check manager logs”

I am not sure this is fully supported. According to Microsoft there are limitations:

Currently, swarm mode on Windows has the following limitations:

  • Data-plane encryption not supported (i.e. container-container traffic using the --opt encrypted option)
  • Routing mesh for Windows docker hosts is not supported on Windows Server 2016, but only from Windows Server 2019 onwards. Users seeking an alternative load balancing strategy today can setup an external load balancer (e.g. NGINX) and use Swarm’s publish-port mode to expose container host ports over which to load balance. More detail on this below.

Browsing on the MS docs I also found this: Getting Started with Swarm Mode | Microsoft Docs

It doesn’t mention Windows 11 pro. If it is possible, you have to make sure that thr required ports are available. You have two special component in this swarm cluster. WSL 2 and a relatively new Windows version where (if I am not mistaken) you can’t even run containers without hyperv isolation unless you build your own image.

right I am having the same issue as being a windows insider doing the beta for win 11 new builds as also have a linux based hp proliant dl380 gen 7 with a mounted windows hyperv 2012 r2 server installed on it and used the wsl cli cmd commands to do everything and now docker wont load correctly even after un install and reinstalled several times

you can’t even run containers without hyperv isolation unless you build your own image. and as such this is correct from my understanding of it as have been on win 11 for about 6 months alpha and beta testing and I did have the docke4r working and since the last update through insider beta its not working now!

You shouldn’t use an insider version of Windows if you want an application to be stable :slight_smile: I am saying it as a former Windows insider. I tried that because I wanted to try a new feature and I knew I could use an other machine if something happens. It worked for some time, I liked that until I started to have more trouble than I could accept.