New type causes "docker desktop unexpected wsl error"

Issue Type: Docker desktop unexpected wsl error
OS Version/Build: Windows 11 10.0.22621.2715
Cloud integration: v1.0.35+desktop.5
Docker version: 24.0.7, build afdd53b
API version: 1.43
Go version: go1.20.10
Git commit: afdd53b
Built: Thu Oct 26 09:08:44 2023
OS/Arch: windows/amd64
Context: default

In this website “Docker Desktop Unexpected WSL Error Fix”, it collects nine causes of such problems and provides solutions. I tried five of these methods and documented the process. Finally I found out that it is a sub error type of Hyper-V. The error occurs from “memory integrity” option.

  1. Docker Settings: My json file is correct and has not been modified.
  2. Config File Modification: I removed the josn file and created a new default josn file. However this does not solve my problem.
  3. Command Line: I tried the “wsl --unregister docker-desktop” command and asked docker to re-register wsl but it was ineffective
  4. Version-Specific: I reinstalled docker 24.0.7, 4.23.0 and 4.22.1. But the problem still occurs.
  5. Hyper-V: I refer to this article to modify hyper-V settings.

In addition to using docker, I also use android (32 bits) VM. But my VM and docker conflict with each other. I adjusted Hyper-V settings during the process of fixing the android VM error. I did not personally modify the “memory integrity option” during the process, but it was indeed modified. So I reverted it and solved this issue type. I searched DOCKER COMMUNITY FORUMS, but there is no discussion of this issue type. Therefore I created a new discussion and share it.

  1. Memory integrity: I refer to this article to modify memory integrity settings.