Docker Community Forums

Share and learn in the Docker community.

Newbi question run images from hub

Hi

I have a question, why when a built an image localy from a Dockerfile am able to run it and when a run the same Dockerfile from docker hub it start and dies whit error 132

I am on a linux Ubuntu16.04 system

could you be more specific?
What happens when you run:

docker run -ti ubuntu:14.04 echo test

Thank you for the reply

I will try to be more specific, I have created a Dockerfile on my local server, I have build the Dockerfile and it works locally on my server when I do docker run “images name”

So I created a GitHub and a Docker Hub account, I have put the Dockerfile in the GitHub account and link it to Docker Hub, Docker hub is able to build successfully the image, now … when I try to run the image locally on my server it pulls the image and run it but it exit right away !!!

So I do docker ps -a and see that the images actually started and exited…

Status
Exited (132) 20 seconds ago


I have tried docker run -it “images name” and still get the same error

Here is what happen when I run what you ask me

Status: Downloaded newer image for ubuntu:14.04
test

Can you provide the repos to us or are they private?

that the container which just runs echo to print “test” exits fast is normal behaviour.

Containers execute just one process. Once the process is finished, the containers are stopped.