No longer able to run Docker for Windows Edge

For some reason I am unable to run Docker for Windows Edge anymore. I’ve uninstall and re-installed several times. Below is the error I am receiving and the crash report id. Any help would be appreciated!

Error response from daemon: Bad response from Docker engine

at Docker.Backend.DockerDaemonChecker.Check(Func`1 isDaemonProcessStillRunning)
at Docker.Backend.ContainerEngine.Linux.DoStart(Settings settings, String daemonOptions)
at Docker.Backend.ContainerEngine.Linux.Start(Settings settings, String daemonOptions)
at Docker.Core.Pipe.NamedPipeServer.<>c__DisplayClass9_0.b__0(Object[] parameters)
at Docker.Core.Pipe.NamedPipeServer.RunAction(String action, Object[] parameters)

Crash report id:

I’m having the exact same issue. Reset to default did’t help and a reinstall didn’t help either.
Luckily I still had an old installer for RC2 where everything works perfectly fine.

diagnostic id: A0C7C63F-2A03-435D-A689-ECC81422B45A/2017-08-23_10-29-05

I also have the same issue on a Windows 10 and on a Windows Server 2016 machine. Reset and reinstall gave the same result. On Windows Server 2016 I could switch to Windows containers. But as soon I switched back to Linux containers I got the same error message as above.
Installing the latest stable version 17.06.1-ce on Windows 10 and everything was fine. I don’t know how to solve the problem on Windows Server 2016 because the docs say that only the latest Edge is compatible.

A description of the same problem you can see on GitHub (Docker for Win).

Unfortunately, i have the same issue with 17.07.0-ce-rc4 and 17.07.0-ce-rc3 :frowning:

17.06.1-ce-win24 works fine (on Windows 10)

I try to start the Docker daemon. After 3-4 minutes i get the message “Error response from daemon: Bad response from Docker engine”.

reinstall, restart, config reset, removing any hyper-v network stuff, … same behavior

Same thing here. Reinstalled today on server 2016. Docker will only start now if run as administrator. Cannot issue commands to docker unless running from an elevated command prompt. Additionally Docker will fail when pulling containers from an insecure registry with some form of segmentation fault… Once the pull fails docker has to be restarted as the daemon goes rouge after. Lots of regressions after the latest two releases of edge.

docker_log.txt (204.7 KB)