Docker Community Forums

Share and learn in the Docker community.

DockerDesktop on WIndows 2.2.0.0 fails to run and fails to uninstall

The update Docker Desktop for Windows v 2.2.0.0 (42247) will error on startup, The application will not uninstall either.
The edge version exhibits the same behavior. I think it was 2.1.7…

Fortunately someone posted a power shell script to remove the application and cleaning the registry so it isn’t in the list of installed applications is fairly easy.
https://success.docker.com/article/how-to-completely-remove-docker-in-windows-10

Also, fortunately I kept my previous installer version 2.1.0.4 (39773) which works perfectly.

It would be nice if broken releases were not pushed out, especially when presented as stable.
I moved off of the edge version because of this and now it occurs with stable releases.

3 Likes

Same issue here. Startup fails and uninstall hangs (forever).

One or more errors occurred.

at Docker.Core.Pipe.NamedPipeClient.d__5.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object parameters)
at Docker.Actions.DoStart(SynchronizationContext syncCtx, Boolean showWelcomeWindow, Boolean withNotifications)
at Docker.Actions.<>c__DisplayClass26_0.b__0()
at Docker.ApiServices.TaskQueuing.TaskQueue.<>c__DisplayClass18_0.<.ctor>b__1()

Previous version (2.1.0.1) worked OK.

Running on Windows 10 Enterprise (1709)

1 Like

Same problem here with 2.2.0.0 and edge 2.1.7.0.

Crash report: DAB04251-CF64-441D-9BB8-3A0F48D4B9FC/20200128092944

I cannot run older versions of Docker as Network Shares are blocked for Docker on our systems.

On some systems Docker 2.2.0.0 works but on a lot it does not.

Same problem for me:
OS: Microsfot Windows 10 Enterprise
Version: 10.0.16299 Build 16299
Docker: 2.2.0.0

   One or more errors occurred.

   at Docker.Core.Pipe.NamedPipeClient.<TrySendAsync>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object[] parameters)
   at Docker.Actions.<>c__DisplayClass39_0.<SwitchDaemon>b__0()
   at Docker.ApiServices.TaskQueuing.TaskQueue.<>c__DisplayClass18_0.<.ctor>b__1()

Note: If I install as windows containers it works fine. But when I switch to using Linux containers it gives the same error.

Downgrading to version 2.1.0.5 has worked fine for me.