Docker Community Forums

Share and learn in the Docker community.

No matching manifest for windows/amd64 10.0.14393

#1

Expected behavior

Expected a verification of successful install by Pulling from library/hello-world

Actual behavior

PS C:\Users\Administrator> docker run hello-world:nanoserver
Unable to find image ‘hello-world:nanoserver’ locally
nanoserver: Pulling from library/hello-world
C:\Program Files\Docker\docker.exe: no matching manifest for windows/amd64 10.0.14393 in the manifest list entries.
See ‘C:\Program Files\Docker\docker.exe run --help’.

Passes docker version and info. Appears to have proper hardware but won’t pass hello_world test

PS C:\Users\Administrator> docker --version
Docker version 18.09.6, build 1578dcadd2

PS C:\Users\Administrator> docker info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 18.09.6
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: ics l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd gelf json-file local logentries splunk syslog
Swarm: inactive
Default Isolation: process
Kernel Version: 10.0 14393 (14393.2969.amd64fre.rs1_release.190503-1820)
Operating System: Windows Server 2016 Datacenter Version 1607 (OS Build 14393.2969)
OSType: windows
Architecture: x86_64
CPUs: 4
Total Memory: 7.999GiB
Name: Hyper-V2
ID: BX4R:VDPC:EEKX:OIW7:FOJY:BIMD:6RFJ:KXVY:GBHA:5SIB:33RQ:4ZH3
Docker Root Dir: C:\ProgramData\docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

PS C:\Users\Administrator> systeminfo

Host Name: HYPER-V2
OS Name: Microsoft Windows Server 2016 Datacenter
OS Version: 10.0.14393 N/A Build 14393
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Server
OS Build Type: Multiprocessor Free
Registered Owner: Windows User
Registered Organization:
Product ID: 00376-50512-40592-AA551
Original Install Date: 4/28/2019, 5:11:03 PM
System Boot Time: 5/17/2019, 6:07:38 AM
System Manufacturer: VMware, Inc.
System Model: VMware7,1
System Type: x64-based PC
Processor(s): 2 Processor(s) Installed.
[01]: AMD64 Family 21 Model 2 Stepping 0 AuthenticAMD ~3512 Mhz
[02]: AMD64 Family 21 Model 2 Stepping 0 AuthenticAMD ~3512 Mhz
BIOS Version: VMware, Inc. VMW71.00V.9694812.B64.1808210100, 8/21/2018
Windows Directory: C:\Windows
System Directory: C:\Windows\system32
Boot Device: \Device\HarddiskVolume1
System Locale: en-us;English (United States)
Input Locale: en-us;English (United States)
Time Zone: (UTC-07:00) Arizona
Total Physical Memory: 8,191 MB
Available Physical Memory: 6,867 MB
Virtual Memory: Max Size: 9,471 MB
Virtual Memory: Available: 8,142 MB
Virtual Memory: In Use: 1,329 MB
Page File Location(s): C:\pagefile.sys
Domain: WORKGROUP
Logon Server: \HYPER-V2
Hotfix(s): 4 Hotfix(s) Installed.
[01]: KB4049065
[02]: KB4485447
[03]: KB4498947
[04]: KB4494440
Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.

Information

Steps to reproduce the behavior

  1. Install based on reference= https://docs.docker.com/install/windows/docker-ee/
#2

I’m having the same issue. Found no solution yet…

#3

Finally found an image that downloaded successfully (download and run):

docker run microsoft/dotnet-samples:dotnetapp-nanoserver-sac2016