Docker Community Forums

Share and learn in the Docker community.

No space left on device error

Thanks worked perfectly for me! You save my monography!

I answered the question on stackoverflow with image - basically used the inbuilt features and clicked Move Image and put it on an external hard disk. initially got the same error - but seems to have resolved.
https://stackoverflow.com/questions/31909979/docker-machine-no-space-left-on-device/46085330#46085330

My dcow was 61GB. I ran the Reset option via the UI, all images were removed. After Docker restarted it was down to 1.5GB.
I then pulled 2 images and dcow size was 5.3GB.
Ran docker system prune -a and all images were deleted but dcow went up to 5.5GB!??
Pulled another image and it went up to 5.8GB (as expected)
6m later without doing anything dcow has gone up to 5.9GB !??
What gives?
Version 17.06.2-ce-mac27 (19124)

Hello,

Removing the orphaned volumes did solve the issue for me.
Thanks you, I did not want to remove all my images and containers.

Agreed @fezvr4sta. The above did not work but I followed that link’s advice and it worked for me. Also freed up several gigs of disk space.

Since I keep coming back here:

1 Like

How is this still an issue over 2 years later? How does volume pruning and image deleting not solve this?

I encountered this error today. I had to delete the following file inorder to make it work
~/Library/Containers/com.docker.docker/Data/vms/0/Docker.qcow2

@mastermindg You are right. pruning and clearing unused images/network/volumes will solve the issue temporarily. Permanent fix is to automatically resize the deleted file

Wow, I’ve been using docker system prune but it does not cleanup the volumes apparently, this is huge.

1 Like

It looks like you can use docker volume prune also…

3 Likes

How is this still an issue in 2020??? The disk does NOT expand past 70GB.

docker volume prune and docker system prune only removed 1.5gb out of the 70gb from my docker disk…

Any clue when this is going to be fixed?

1 Like

docker system prune reclaimed back 13.8 GB on my Mac though(Mojave 10.14.6) & Docker Desktop-2.2.0.3)

Thank you for the tip. It saved my whole day!

I have written a blog article with all the tricks I could imagine regarding the “No space left on device” :

I hope it can help!