Docker Community Forums

Share and learn in the Docker community.

No such file or directory - unable to open layers

beta
docker

(Theonlysean) #1

Hi There,

I’m having an issue running one of my docker files. When I run Docker build . I get the following error:
open /var/lib/docker/aufs/layers/9319fd93cb6d6718243ff2e65ce5d2aa6122a1bb9211aa9f8e88d85c298727e5: no such file or directory

I’ve tried to remove all container and images. Not sure what else to try.

Any help is appreciated.

!-- docker file

FROM node:6

RUN git clone https://github.com/preboot/angular2-webpack.git

WORKDIR angular2-webpack

RUN sed -i.bak ‘s/–port 8080/–host 0.0.0.0 --port 8080/’ package.json
RUN npm i

CMD [ “npm”, “run”, “start” ]

!-- diagnostics

Docker for Mac: version: 1.12.1 (2d5b4d9)
OS X: version 10.10.5 (build: 14F1909)
logs: /tmp/A2516EE7-394A-4DF9-A27F-071517BD2B2F/20161010-202408.tar.gz
[OK] docker-cli
[OK] virtualization kern.hv_support
[OK] menubar
[OK] moby-syslog
[OK] dns
[OK] disk
[OK] system
[OK] app
[OK] osxfs
[OK] virtualization VT-X
[OK] db
[OK] slirp
[OK] logs
[OK] env
[OK] vmnetd
[OK] moby-console
[OK] moby
[OK] driver.amd64-linux

Finally, if your issue has not been addressed elsewhere, running:

  • :whale: :arrow_right:️ Diagnose & Feedback… :arrow_right:️ Diagnose & Upload :arrow_right:️ Open Issues.

This forum is not an official product support or issue reporting channel.