Not able to Pull the Image from DockerHub - 11-11-2023

I am not able to pull the any of the images from the docker hub. If the image is already present in cache, the image pull is happening correctly. But I am not able to pull any fresh image from the docker hub.

I have tried this in WSL Ubuntu,


Trying to pull Docker
WARN[0018] failed, retrying in 1s … (1/3). Error: initializing source docker://amazonlinux:latest: Get “”: EOF

Can I know whether there is any issue with DockerHub ?

It’s a known issue. They are working on it:

I’m seeing the same issue on Ubuntu 22.04. Here is my docker version:

Docker version 24.0.7, build afdd53b

Here is what I’m seeing:


1 | >>> FROM ubuntu:18.04

ERROR: failed to solve: ubuntu:18.04: failed to do request: Head “”: EOF

I find if I do “docker logout”, sometimes I can get my “docker build” command to work.

Great ! Good to know

Same on GitHub: many CI launches are red:

It looks like it works now. At least for me. The status page still shows that they are monitoring (since 18:15 UTC) the system to make sure everything was resolved, but I could pull the image I couldn’t before.