Docker Community Forums

Share and learn in the Docker community.

Can't pull from DockerHub

Hi everybody,
I can’t pull any image from DockerHub.

What I try:

 ~ docker pull jenkins                                                                                                                       
Using default tag: latest
Error response from daemon: manifest for jenkins:latest not found: manifest unknown: manifest unknown

More in debug mode:

Dec 24 17:53:40 supervoid dockerd[429]: time="2020-12-24T17:53:40.653500970+03:00" level=debug msg="Calling HEAD /_ping"
Dec 24 17:53:40 supervoid dockerd[429]: time="2020-12-24T17:53:40.654170989+03:00" level=debug msg="Calling GET /v1.41/info"
Dec 24 17:53:40 supervoid dockerd[429]: time="2020-12-24T17:53:40.681975505+03:00" level=debug msg="Calling POST /v1.41/images/create?fromImage=jenkins&tag=latest"
Dec 24 17:53:40 supervoid dockerd[429]: time="2020-12-24T17:53:40.683801116+03:00" level=debug msg="Trying to pull jenkins from https://registry-1.docker.io v2"
Dec 24 17:53:43 supervoid dockerd[429]: time="2020-12-24T17:53:43.745778865+03:00" level=info msg="Attempting next endpoint for pull after error: manifest unknown: manifest unknown"
Dec 24 17:53:43 supervoid dockerd[514]: time="2020-12-24T17:53:43.858859069+03:00" level=debug msg="garbage collected" d=2.082917ms
Dec 24 17:56:49 supervoid dockerd[429]: time="2020-12-24T17:56:49.831321928+03:00" level=debug msg="Calling HEAD /_ping"
Dec 24 17:56:49 supervoid dockerd[429]: time="2020-12-24T17:56:49.832148325+03:00" level=debug msg="Calling GET /v1.41/info"

What I expect:

Successfully pulled image

Details:

 ~ docker info
Client:
 Context:    default
 Debug Mode: false
 Plugins:
  app: Docker App (Docker Inc., v0.9.1-beta3)
  buildx: Build with BuildKit (Docker Inc., v0.5.1-tp-docker)

Server:
 Containers: 0
  Running: 0
  Paused: 0
  Stopped: 0
 Images: 12
 Server Version: 20.10.1
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: false
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Cgroup Version: 1
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 269548fa27e0089a8b8278fc4fc781d7f65a939b.m
 runc version: ff819c7e9184c13b7c2607fe6c30ae19403a7aff
 init version: de40ad0
 Security Options:
  seccomp
   Profile: default
 Kernel Version: 5.9.14-arch1-1
 Operating System: Arch Linux
 OSType: linux
 Architecture: x86_64
 CPUs: 4
 Total Memory: 7.686GiB
 Name: supervoid
 ID: 4QDZ:P3EC:4R5J:TG6K:X7EJ:SDWQ:U2ZC:ZILU:M7IM:YUOT:PHKK:CVQQ
 Docker Root Dir: /var/lib/docker
 Debug Mode: true
  File Descriptors: 25
  Goroutines: 39
  System Time: 2020-12-24T17:56:49.832775899+03:00
  EventsListeners: 0
 Username: ep4sh
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false

WARNING: No blkio weight support
WARNING: No blkio weight_device support

I am not limited to pull images:

 ~ curl --head -H "Authorization: Bearer $TOKEN" https://registry-1.docker.io/v2/ratelimitpreview/test/manifests/latest 2>&1 | grep RateLimit
RateLimit-Limit: 200;w=21600
RateLimit-Remaining: 198;w=21600

How can I fix it?
Appreciate any help, thanks in advance!

Hi,
I need to admit, I am just learning docker and tried to pull Jenkins image as I am following a tutorial but I faced the same issue.
I resolved it by pulling Jenkins from a different repository.
“docker pull jenkins/jenkins”
Hope it may help you.

Regards,
Kannan

Hi,
I had the same problem and it worked with your suggestion. Thank you!

Regards,
Magor