Docker Community Forums

Share and learn in the Docker community.

Odoo 13, Restoring A Database Backup Always Fails

Hello,

I’m new in the forum and I need some assistance with Docker.
To begin with, I have been tasked by my boss to develop an Odoo suite for our business which includes accounting and website modules. Most of this has been done and tested on a local machine, I just need to refine the overall presentation and other non-critical functionalities.

Just recently, my boss had bought a NAS (Synology DS718+, Docker compatible) for the business and he would like our Odoo project to be hosted on that NAS. He even bought domain names so every employee can access the Odoo suite without having to connect to the office WiFi.

Since there were no Odoo 13 package in the Synology package resource, I’ve installed Docker on the NAS and downloaded the Odoo 13 image with it. Creating, duplicating, and running database with it was good, it works as intended. However, the problem arises when I tried to restore a database backup which I’ve developed with Odoo on a local machine.

Whenever I try restoring the backup on the NAS, it always takes a long time and ultimately the connection timed out after 150 seconds (this may be a clue, if I need to configure the time limit). The partly restored database cannot be accessed and gives an internal server error. Creating a backup from the NAS and restoring it in the local machine Odoo also results in the same error. So it seems there may be something with the Synology NAS or Docker that may have interfered with Odoo’s backup and restore process.

Does anyone have any suggestions? Any leads are appreciated

When you restore a backup you need to make sure that the database name does not already exist.
So backup dataA should become dabtaB if dataA instance already exists.
The result will be that you have dataA and dataB in the odoo instance and either can be started.