Docker Community Forums

Share and learn in the Docker community.

On each restart of Windows 10 Docker wants to install a new version 1.12.3

docker

(Taocode) #1

Each time I start Windows 10, a dialog pops up “A new version of Docker is available”. After I install this new version and I restart Windows, that same popup shows up again for the same version of Docker. There are no error messages in the event log regaring the installation of Docker.
What could be the problem?
Where can I check what went wrong?


(Michael Friis) #2

Can you please run the in-app diagnostics and open an issue here? https://github.com/docker/for-win/issues


(Hejado) #3

Have you tried manually installing it using the installer?

The auto update function didn’t work for 1.12.2 (iirc), maybe it’s similar with 1.12.3.


(Taocode) #4

@hejado: Yes, I tried downloading and installing 1.12.3. Indeed it worked. Now when I restart my computer, Docker does not suggest installing 1.12.3 anymore.

The issue is resolved for me. But as you say, the auto update function for 1.12.3 might not work.