Docker Community Forums

Share and learn in the Docker community.

Overlay Network Error: Cannot start container

(Dan Jones) #1

I’ve been attempting to test drive the latest networking features in 1.9 and have been unsuccessful. I’m using Consul as the KVS and docker-machine to provision a new host. The main network is 10.0.0.0/24.

Create new host:
docker-machine create -d generic --generic-ip-address=10.0.0.5 --engine-opt"cluster-store=consul://10.0.0.1:8500" --engine-opt=“cluster-advertise=10.0.0.5:0” net-demo0

On the new host (net-demo0) I create the following network:
docker network create -d overlay --subnet=10.1.0.0/16 overlay-0

I then run a new container:
docker run -itd --name=web --net=overlay-0 nginx

It fails with the following:
Error response from daemon: Cannot start container : subnet sandbox join failed for “10.1.0.0/16”: vxlan interface creation failed for subnet “10.1.0.0/16”: failed in prefunc: failed to set namespace on link “vxlana9198e”: invalid argument

I have no clue what I’m doing wrong. Thanks!

1 Like
(Dan Jones) #2

Problem solved - I didn’t realize overlay networking isn’t supported on Kernel versions <3.15. The error msg could be improved.

(Sbex) #3

This requirements (kernel > 3.15) should be mentionned in the documentation (LTS ubuntu comes with 3.13)

(Toughrice) #4

So you solved it by upgrade Kernerl versions? Is there any else solution?

(Dan Jones) #5

Yes, that addressed it.