Overnight change broke docker compose when using syntax tag in dockerfiles

I had this line in my dockerfiles # syntax=docker/dockerfile:1 as was recommended as best practice.

Using docker compose build with a docker-compose.yml that refers to these dockerfiles. I work in an ssh context on an remote ipv6 only server. This worked without any hitch up to 22nd of April.

Now after the weekend I can still access and control my remote context. However 'docker compose build` gives an error.

failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to solve with frontend gateway.v0: failed to do request: Head "https://registry-1.docker.io/v2/docker/dockerfile/manifests/1": dial tcp connect: network is unreachable

I restarted the server, the docker daemon, enabled/disabled buildkit, logged into registry.ipv6.docker.com again, but nothing worked. Removing `# syntax=docker/dockerfile:1’ resolves the issue, but goes against best practice.

Did some network things change on the docker side. Is https://registry-1.docker.io/v2/docker/dockerfile/manifests/1 suddenly not accessible through ipv6?