Docker Community Forums

Share and learn in the Docker community.

Portainer version 1.16.3 not connecting to docker on windows 10

docker

(May92017) #1

Hi,
I recently pulled down the latest version of portainer (1.16.3) and I find that with this version portainer fails to connect to the endpoint. I am working on windows 10 with Docker Version 17.09.0-ce-win33 (13620).

The command I am using is setup for linux :

docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock -v ${ICSDEV_HOME}/portainer/endpoint.json:/endpoint.json --name portainer-webapp --label portainer-hide=true portainer/portainer --no-auth --external-endpoints /endpoint.json

and is using this endpoint.json file:
[
{
“Name”: “my-local-endpoint”,
“URL”: “unix:///var/run/docker.sock”
}
]

So it isn’t setup specifically for windows but it has always worked previously. I have tried to configure for windows, exposing the daemon on 2375 and configuring the endpoint manually but I still cannot connect.

Is there some issue with this version of portainer, should I be able to connect to 2375 after exposing the daemon?


(deviantony) #2

Hey @may92017

This issue might be related to the --external-endpoints flag… I’m not sure. Could you test without this flag and tell us if it’s working?

Also, you can join our community support on Slack at https://portainer.io/slack/

We’ll be able to help you faster in here.

Cheers !