Docker Community Forums

Share and learn in the Docker community.

Problem pulling docker image on VPS

docker

(Brian Phillips) #1

I’m running a Ubuntu 14.04 VC2 & Ubuntu 14.04 Storage Instance from Vultr.com.

I’ve setup the private network so they see each other.

I mounted the storage instance with sshfs root@x.x.x.x: /storage.

I’ve installed the docker version from docker.com and removed ‘apt-get remove --purge docker.io’ version. That solved the FATA issues I was getting.

I copied /var/lib/docker/* to /storage and created a symlink with ln -s /storage /var/lib/docker. Yes I removed /var/lib/docker before the symlink.

I did a ‘docker run hello-world’ and it worked. However, when I do a ‘docker pull ubuntu:14.04’ OR ‘docker pull myrepo/myimage:1.0’ it will download and extract but at the very end I get this error:

failed to register layer: Error processing tar file(exit status 1): lchown /bin/bzcmp: no such file or directory

The path exists, it’s a symlink.

I’ve pulled the image to my localhost, also with a symlink, and it works. Also, when I was running purely off a storage instance (extremely slow - don’t do it) the docker image did work. So, it’s not the image itself.

I’ve tried searching for this error and can’t find anything about it. Any idea what’s going on?