Docker Community Forums

Share and learn in the Docker community.

Problems having restore docker ucp


(Avinashaurea) #1

Hi team ,

When I trying to restore the ucp containers on different primary host with same Ip it gives me following error as shown in the log

root@ip-10-69-11-99:/opt# docker run --rm -i --name ucp \

-v /var/run/docker.sock:/var/run/docker.sock \
docker/ucp restore < backup.tar
INFO[0000] Your engine version 1.12.3-cs3, build 781bb16 (4.4.0-47-generic) is compatible
FATA[0000] This node is not a controller. In the future if you encounter problems on this node, re-run the ‘join’ command to reconnect to the cluster.
read unix @->/var/run/docker.sock: read: connection reset by peer

This was running on a host after installation I had taken backup of this ucp primary controller as given in the doc and moved the tar file in S3 but after some time due to some disk corruption the ec2 instance became unavailable .
So i terminated that ucp docker host and recreated the new host with the same Ip and tried to restore it from the tar file but it didn’t worked out .

can u please tell what files are required so that it might work with the smae configuration as it was working earlier