Docker Community Forums

Share and learn in the Docker community.

Problems with "data-root" on external drive

Hi, I’m still a bit new to docker and I’ve been trying to use it to set up a NextCloudPi instance on an AtomicPi running Ubuntu Server 18.04 LTS, in order to save writes and since it has so much more space I wanted to make my default data directory /media/usbhdd/docker by adding data-root to the daemon.json but if I do so it will hang after clicking activate saying “Initializing NextCloudPi for the first time Please wait”

It will install fine if leave it at the default location, so I can work around this by either leaving it and using -v /media/usbhdd:/data or install it then move the folder and have a working instance, but I would really like to know why moving the data folder to my drive is screwing up the setup, I’ve tried messing with permissions/ownership of the docker folder, double-checked my fstab is fine, tried symlinks instead and even beating my face in with a mouse but none of those have solved my problem.

Also, would someone mind telling me the recommended way of viewing logs since you can’t use nano or other text editors?

I solved my issue by loading up Linux Mint and reformatting the drive using gparted then making a new docker folder all through the GUI so there’s pretty much no way I could screw it up and now it works as I intended it to.