Docker Community Forums

Share and learn in the Docker community.

Proxy configuration the right way


(4integration) #1

Hi,

Running boot2docker on Windows 8.1 on my computer at work which is behind a HTTP proxy server. So I wonder about the best/correct way to do this configuration.

I have configured /var/lib/boot2docker/profile in boot2docker.iso to tell

export HTTP_PROXY=http://UserName:Password@companyproxy.host.com:8080
export HTTPS_PROXY=https://UserName:Password@companyproxy.host.com:8080

Issue 1: To have this configuration in clear text isn’t the nicest way, is it possible to handle it in another way?
Issue 2: When I change my password (forced regularly) I also must update this.

With this configuration I can execute:

docker@boot2docker:~$ docker search tutorial
NAME                                       DESCRIPTION   STARS     OFFICIAL   AUTOMATED
learn/tutorial                                           8
caterpillar/java-tutorial                                2
...etc

But when executing wget or curl I get e.g.:

docker@boot2docker:~$ wget http://distro.ibiblio.org/tinycorelinux/5.x/x86/tcz/cifs-utils.tcz
wget: bad address 'distro.ibiblio.org'

Issue 3: Why does that happen with wget/curl but not with docker?


(Shay Tsadok) #2

Have the same problem…


(Gerardo Lisboa) #3

Add the “-Y on” on your wget options.
wget -Y on ...

curl seems to follow the http_proxy value by default.