Docker Community Forums

Share and learn in the Docker community.

Pull access denied error

I’m trying to run a docker image pull command :
C:\Users\Mercy\AppData\Local\Google\Cloud SDK>docker image pull us.gcr.io /patch-homes-data-science/ds-pipeline

and I’m getting the error:

Using default tag: latest
Error response from daemon: pull access denied for us.gcr.io /patch-homes-data-science/ds-pipeline, repository does not exist or may require ‘docker login’: denied: Permission denied for “latest” from request “/v2/patch-homes-data-science/ds-pipeline/manifests/latest”.

I tried docker login. and then tried this command, still getting the same error.

Why is it saying repository doesn’t exist? How can I check Am I giving the right repository name?
Can anybody please help me in resolving this issue.

Hi, its not the right format.

its docker image pull something/image:version and not “google cloud platform”

Hi I wrote the actual code, but it is taking it as link format. This is the command I used, im adding an extra space after io so that it dont turn into a link : docker image pull us.gcr.io /patch-homes-data-science/ds-pipeline

I also would like to know how I can create a new image pointing to the recent commits of the repository