Docker Community Forums

Share and learn in the Docker community.

Pull error "\"The Repository is Locked, access denied\""


(Moonsyim) #1

Would you give me some idea how to fix this pull error ?

docker pull moonsyim/amazon-linux-ami-tomcat-20150630:0.5

Pulling repository moonsyim/amazon-linux-ami-tomcat-20150630
FATA[0001] Error: Status 403 trying to pull repository moonsyim/amazon-linux-ami-tomcat-20150630: ““The Repository is Locked, access denied””

docker version

Client version: 1.6.2
Client API version: 1.18
Go version (client): go1.3.3
Git commit (client): 7c8fca2/1.6.2
OS/Arch (client): linux/amd64
Server version: 1.6.2
Server API version: 1.18
Go version (server): go1.3.3
Git commit (server): 7c8fca2/1.6.2


(Moonsyim) #2

my solution was

upgrade docker account - free to Micro
docker logout
docker login
after that try again, now it works.


(Mark Drury) #3

Sadly, I’m seeing the same error trying to pull one of my public repos to an AWS EC2 instance (didn’t work for my private repos, either). I then upgraded my account from the free tier to $12/month for ten private repos, logged out and back into docker on the instance, and still see the error. There must be something else at play here…


(Mark Drury) #4

Okay, looks like I can now pull other private repos to my EC2 instance after upgrading my account, but not the two which originally exhibited the problem. I’ve make those problematic repos both public and private, logged in and out and still no luck. Is this simply a caching issue which will clear itself or need I pre-empt in some way?


(Moonsyim) #5

Oh…, later I got a message from Sabin Basyal (Docker)

He said my repositories are unlocked, it was just because of the old cache, manually cleared the cache.
After that it works. why don’t you do “Submit a New Request” in https://hub.docker.com/ -> Help, then Docker guys will help you.


(Sabin Basyal) #6

@markdrury
Can you list which two repos are locked, if the haven’t been unlocked already?


(Mark Drury) #7

@sbasyal, thanks for your quick response. The two repos in question, which still exhibit the same error on pull requests as of this morning, are markdrury/taas-models:v1 and markdrury/taas-libs:v1.


(Sabin Basyal) #8

@markdrury, I have cleared the cache for you. You should be good now!

Regards,
Sabin


(Mark Drury) #9

Thanks, @sbasyal – I was able to pull both repos on the AWS instance a few minutes ago, so things look good on my end.


(Sabin Basyal) #10

For all new users referring to this problem, this problem are mainly caused if a user has his Global Settings set to Private and they push new repository using Docker CLI. Then it instantly creates a repository, set the visibility to Private and then gets locked, if you do not have free private repo.
We will fix this issue of not getting unlocked on its own when converted back to public on our end but until then if you encounter such problem, please change your default repository visibility to Public and push or create private repo from WebUI and then push to that private repo.


(Giumbai) #11

Hope it gets fixed! Just had the same problem! I Did exactly what you said created another private repo and so on and it still doesn’t works.


(Pankotek) #12

It seams this workaround still does not work for me.


(Sabin Basyal) #13

In that case, send an email to support@docker.com mentioning which repository is locked and we will unlock it for you.

Regards,
Sabin


(Upsalsa) #14

I deleted the repository in hub.docker.com then manually created the repo as public.
After that I executed the push command.


(Jonesp) #15

Is there any update on this?
Making the default visibility of repo’s be public doesn’t fit well with our workflow of “create new repos as part of dev, have them private, then promote to public downstream”


(Darryl Rubarth) #16

Having the same issue. I have the free account as I figure out Docker and I need to keep my repo private. This seem to be a long standing issue that really needs to be fixed.