Querying com.docker.backend process: permission denied

I run docker 4.26.1 on linux 22.04 with nextcloud and mysql and php working on lamp, I have no proxy
When keying http:myip:9980/ I get to /var/www/html
I ran docker pull collabora/code and then
docker run -t -d -p IP_D-ECOUTE:9980:9980 -e ‘domain=decidim.ovh’ --restart always --cap-add MKNOD collabora/code
and get the error message docker: invalid IP address: IP_D-ECOUTE

Any idea of what could wrong ?


Why would it be valid?

I wished collaborat ran in order to let me Access to it. But unfortunately, After thé error, I get no container

The question remains. You shared an obviously invalid IP, since it is not an IP just some kind of placeholder. Let’s say the aplication in the container supports that placeholder. Docker is not that application so Docker’s parameters ill not support it.

Hi I answer myself
I ran collabora in the docker desktop itself and it works ok.
Then, I got to key https://localhost:9980 in order to get collabora work (instead of http)
Thank you