Docker Community Forums

Share and learn in the Docker community.

Docker CE behind corporate firewall and CentOS7 / no tips work / details below

Hi all,

before I post my issue, here are some details to work with:

uname -a:
Linux themaster 3.10.0-957.12.1.el7.x86_64 #1 SMP Mon Apr 29 14:59:59 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

docker version:
[chris@themaster ~]$ docker version
Client:
Version: 18.09.5
API version: 1.39
Go version: go1.10.8
Git commit: e8ff056
Built: Thu Apr 11 04:43:34 2019
OS/Arch: linux/amd64
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 18.09.5
API version: 1.39 (minimum version 1.12)
Go version: go1.10.8
Git commit: e8ff056
Built: Thu Apr 11 04:13:40 2019
OS/Arch: linux/amd64
Experimental: false

My issue is that when I run docker login this happens:

[chris@themaster ~]$ docker login
Login with your Docker ID to push and pull images from Docker Hub. If you don’t have a Docker ID, head over to to create one.
Username: xxxxx
Password:
Error response from daemon: Get registry-1.docker.xx/v2/: net/<<: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

What I’ve done so far:

Created /etc/sysconfig/docker with entry:
[Service]
Environment=”HTTP_PROXY="my proxy server address”


Also created (according to the docker article)
sudo mkdir etc/systemd/system/docker.service.d/
Created a file called /etc/systemd/system/docker.service.d/http-proxy.conf that adds the HTTP_PROXY environment variable:

[Service]
Environment=“my proxy which works for yum and everything else”

This was taken from: https://docs.docker.com/v17.09/engine/admin/systemd/#runtime-directory-and-storage-driver

sudo systemctl daemon-reload

sudo systemctl restart docker

systemctl show --property=Environment docker
Environment=

The environment variable is empty. I tried this mulitple times. I configured the web proxy we use (no user authentication required) and the web browser and yum work fine. RPM accepts the proxy with the http_proxy parameter fine. It’s just Docker that’s having the issue with the proxy. I spent reading tons of articles but no solution has helped me so far.

Does anyone else have any ideas please that I could try?

Many thanks,

Chris

P.S: As newbie I can’t paste more than two links so I crippled some.