Docker Community Forums

Share and learn in the Docker community.

RPi4 docker and wlan0

I’m running Ubuntu 18.04 on a RPi 4 with Docker 19.03.6. The Pi is wired into on vlan on eth0 and on another vlan with wlan0. The host can ping both gateways. Docker has both networks created as follows:

docker network create -d macvlan --subnet= --gateway= -o parent=eth0 lan
docker network create -d macvlan --subnet= --gateway= -o parent=wlan0 iot

I’ve tried a few different containers and none of them can ping the wlan0 gateway, but can ping the eth0 gateway. Any suggestions?

1 Like

I am facing the same issue, the Wi-Fi gets disconnected after starting one docker container.

The issue has been temporarily resolved by disabling the static IP.

Check the file - /etc/dhcpcd.conf, make sure all the static IP mapped with wlan0/SSIDs are commented out.

Reboot the Raspberry Pi.

Start the container.

Hope it works for you too.

Hi there,
I am using a RPi 4 and installed wlan0. Everything worked fine.
After that i installed docker (IOTstack) and run the container.

After reboot following happens:
wlan0 tried to get established but fails. dhcpcd Not running

I watched Docker starting up. in my opinion the fault is caused by Docker.

Any hint?


same problem here! Any solution ?