Run multiple prerequisite exe on docker container

I want to build a complex legacy .net framework project on a docker container. There are quite a few prerequisite executables to be installed before building the solution. I have created a dockerfile with windows servercore 2019 base image as follows

COPY . ./
RUN powershell Start-Process vld-2.5.8-setup.exe
RUN powershell Start-Process jdk-7u25-windows-i586.exe
RUN powershell Start-Process jdk-7u25-windows-x64.exe 
#need to install few more build tools

When I build the image using

docker build -t consoleapp_image . 
Step 1/6 : FROM
 ---> 997b460651ea
Step 2/6 : WORKDIR /App
 ---> Using cache
 ---> 1cd3b9f95bc9
Step 3/6 : COPY . ./
 ---> 871ad7a1c8f2
Step 4/6 : RUN powershell Start-Process vld-2.5.8-setup.exe
 ---> Running in eb11a9479c64
Removing intermediate container eb11a9479c64
 ---> 8330a331897d
Step 5/6 : RUN powershell Start-Process jdk-7u25-windows-i586.exe
 ---> Running in d95c69f4296f
Removing intermediate container d95c69f4296f
 ---> f3a1f0fe8819
Step 6/6 : RUN powershell Start-Process jdk-7u25-windows-x64.exe
 ---> Running in 46437b28ab84
Removing intermediate container 46437b28ab84
 ---> ba2d168b87b2
Successfully built ba2d168b87b2
Successfully tagged consoleapp_image:latest

I could see the output as successfully built image, but I am not sure whether they have actually been installed as I am unable to find any installed folders when I tried to run the image using any of the following commands

docker exec -it container powershell
docker run -it consoleapp_image
  1. Is RUN powershell Start-Process the right command to install any prerequisite?
  2. I cannot see any installed folders in C:/Program Files or C:/Program Files(x86), how do I ensure the exes are installed correctly?

Also tried silent installation, but the image never got created

RUN powershell Start-Process vld-2.5.8-setup.exe -ArgumentList '/i', '/quiet', '/norestart' -NoNewWindow

Appreciate your help

This is not a reply, I am adding some more notes as I am not able to edit the post.
On local machine, I have got silent installation sorted out and I tried the same command as below on dockerfile

RUN powershell Start-Process jdk-7u25-windows-i586.exe -ArgumentList '/s'

Image has got created, but still I am not able to see any installed folders anywhere on the container

Resolved jdk installations by

RUN powershell Start-Process jdk-7u25-windows-i586.exe -ArgumentList '/s' -Wait
RUN powershell Start-Process jdk-7u25-windows-x64.exe -ArgumentList '/s' -Wait

However, vldsetup.exe is throwing a popup to accept license agreement. ArgumentList ‘./accepteula’ isn’t making any difference