Docker Community Forums

Share and learn in the Docker community.

Server Core 1709 issues


(Khutch6) #1

Good day, all! Total newbie to Dockers here, but I really wanted to get this up and running in my Hyper V lab. Some details: Physical host is Server 2016, v 1607. The VM that is to be the container host has nested virtualization and MAC spoofing exposed/enabled.

Expected behavior

Docker can pull images from docker repository

Actual behavior

When pulling a linux container:
PS C:\Users\Administrator> docker pull supertest2014/nyan
Using default tag: latest
latest: Pulling from supertest2014/nyan
a3ed95caeb02: Download complete
e472211e4879: Extracting [==================================================>] 67.49MB/67.49MB
bba4bc236bcb: Download complete
9d52b79a9349: Download complete
c1f720c0024d: Download complete
failed to register layer: failed to start service utility VM (applydiff e0b18dddf900b3c366ca3d6ced455c713682f1535dc135098f92eee6266a78d4): container e0b18dddf900b3c366ca3d6ced455c713682f1535dc135098f92eee6266a78d4_svm encountered an error during CreateContainer: failure in a Windows system call: A connection could not be established with the Virtual Machine hosting the Container. (0xc0370108) extra info: {“SystemType”:“container”,“Name”:“e0b18dddf900b3c366ca3d6ced455c713682f1535dc135098f92eee6266a78d4_svm”,“Layers”:null,“HvPartition”:true,“HvRuntime”:{“ImagePath”:“C:\Program Files\Linux Containers”,“LinuxInitrdFile”:“initrd.img”,“LinuxKernelFile”:“bootx64.efi”},“ContainerType”:“linux”,“TerminateOnLastHandleClosed”:true,“MappedVirtualDisks”:[{“HostPath”:“C:\ProgramData\docker\lcow\scratch\e0b18dddf900b3c366ca3d6ced455c713682f1535dc135098f92eee6266a78d4.vhdx”,“ContainerPath”:"/tmp/scratch",“CreateInUtilityVM”:true,“AttachOnly”:false}]}
PS C:\Users\Administrator> docker network ls
NETWORK ID NAME DRIVER SCOPE
209202d5e319 nat nat local
c014eb46d0a1 none null local

When pulling a Windows base OS:
PS C:\Users\Administrator> docker pull microsoft/nanoserver
Using default tag: latest
latest: Pulling from microsoft/nanoserver
bce2fbc256ea: Download complete
cb1aafb71473: Download complete
unexpected EOF

Information

C:\Users\Administrator>ver

Microsoft Windows [Version 10.0.16299.248]

C:\Users\Administrator>docker version
Client:
Version: 17.10.0-ee-preview-3
API version: 1.33
Go version: go1.8.4
Git commit: 1649af8
Built: Fri Oct 6 17:52:28 2017
OS/Arch: windows/amd64
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.33/version: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

Steps to reproduce the behavior

1 Install fresh copy of Server 1709 Core
2 Windows Updates for all available updates
3 Install-Module DockerProvider
Install-Package Docker -ProviderName DockerProvider -RequiredVersion preview
4 [Environment]::SetEnvironmentVariable(“LCOW_SUPPORTED”, “1”, “Machine”)
Restart-Service Docker


(Khutch6) #2

update: also tried setting LCOW_API_PLATFORM_IF_OMITTED to no avail


(Gpussetto) #3

I have the exact same error while trying to create linux containers using create-compose on windows 2016 1709.
Hopefully there is a solution soon.


(Ntweekly) #4

Hi There,

Please use the article below

If you follow the steps it will work.


(Khutch6) #5

I followed those steps exactly (as indicated in the original post) and have reproduced the same issue in several different environments.


(D95096201) #6

Hello ,
Did you find a solution to this problem by now ?

Thanks.