Docker Community Forums

Share and learn in the Docker community.

Silence the Snyk message after docker build

I find the Synk message after my docker build command distracting because it looks like something went wrong with the build and I want to remove the message. I looked through the environment variables documentation at https://docs.docker.com/engine/reference/commandline/cli/#environment-variables but I didn’t find anything. How do I silence the Snyk message?

The following is an example of the output:

$ docker build -t demoapp .
[+] Building 1.1s (12/12) FINISHED
# ...

Use 'docker scan' to run Snyk tests against images to find vulnerabilities and learn how to fix them

The Snyk Container command line interface (CLI) helps you find and fix vulnerabilities in container images on your local machine.

Install the Snyk CLI
Use any of the following:

npm – npm install -g snyk
Homebrew – brew tap snyk/tap && brew install snyk
Scoop - scoop bucket add snyk GitHub - snyk/scoop-snyk: A Scoop Bucket for Snyk, making installation on Windows easier
A manual installer available from GitHub
For more detailed installation guidance and options, see Install the Snyk CLI.

I would also like to silence this Synk message, especially when running docker build --quiet. Including this extra message breaks some local debugging conveniences I use, like

docker run --rm `docker build --quiet .`

since the standard output of the build command is no longer only the built image ID.

Is there a way to opt out of Synk altogether?