SoGO showing "No mailbox selected" in mailcow installed with docker and docker-compose

I run a local ubuntu server machine with static ip and a local windows 10 client all on virtualbox. Im wondering what causes this to happen because it did not happen in the video I was following. Video: Install a mail server on Linux in 10 minutes - docker, docker-compose, mailcow - YouTube

Instead of sharing videos to an external resource, please share what you exactly did (as in exact commands and if used compose file), and what the expected outcome should be, and how the current outcome deviates from the expectation.


I did exactly the same on Ubuntu 22.04 and run into exactly same problem.

Compared to these instructions videos/mailcow-tutorial at main · ChristianLempa/videos · GitHub the only difference I did was different mailserver FQDN, timezone and SKIP_LETS_ENCRYPT= I set to n.

I Googled the error message and found a post from someone who had the same problem. The person was suggesting that in E.Mail → Configuration → Mailboxes → Edit mailbox → “Allowed protocols” you should enable also IMAP and POP3. I had only SMTP and Sieve. So I enabled IMAP and POP3 and rebooted. Now Mailcow has been working for two days (that was when I enabled the protocols).

To me it sounds that there is something wrong with Docker Mailcow since it is strange that these type of changes “fix” the problem.

All problems solved for me when I enabled internet connection. I thought only the installation required internet but the startup also needed it apperantly. It even worked after removing internet connection after starting mailcow, but if I restarted SOGo after removing internet it stopped working.