Docker Community Forums

Share and learn in the Docker community.

[SOLVED] Bridging Issue? (Non-Responsive Docker Services)


(Humanjhawkins) #1

I am running a fresh install of Ubuntu Server 18.04 via Hyper-V with distinct physical network ports/distinct IP addresses for the host and VM. I believe the host, VM and virtual switch are all configured correctly, as the following all work as expected:

  • internet on both host and VM
  • network discovery and file sharing on the host (no samba on the VM to test this)
  • ping to both host and VM responds < 1ms from local lan

I then installed docker (bionic stable) and docker compose, and tested with the hello world container. This worked as expected.

Finally, I cloned and built Ryan Ewen’s lan-cache-docker per the instructions at https://github.com/RyanEwen/lan-cache-docker/wiki/Setup-instructions. The build process appeared to work as intended, and the three containers are running.

And now, the problem… An nslookup to the VM’s IP does not respond. Also, I notice the “PORT” column returned for these services with docker ps is empty. That seems incorrect.

The 15 stars on Mr. Ewen’s repo tell me that hundreds of people are successfully using this. But I am new enough to docker that I am unsure where to start with troubleshooting. Any help would be appreciated.

Thanks in advance.


(Humanjhawkins) #2

SOLVED: It’s always the simple things. systemd-resolved was already running on port 53 (must be default on Ubuntu Server 18.04, probably others). So dnsmasq failed to start.

The solution was:

  1. Edit /etc/systemd/resolved.conf, setting DNSStubListener=no. This turns off listening on port 53.
  2. I rebooted and found dnsmasq just worked, but you could sudo systemctl restart systemd-resolved and then start dnsmasq if that works better.