Docker Community Forums

Share and learn in the Docker community.

Solved - Can't log in to DockerHub - OS X mac-v1.12.0-beta16.2

dns
beta
dockerhub

(Christian Desserich) #1

So, I wanted to share something that I ran into. I couldn’t log in to DockerHub, couldn’t pull images, etc. I went through a ton of troubleshooting - restarted Docker, restarted my machine, reset Docker, reinstalled Docker, restarted my machine again. Nothing was working. I switched to another network and, boom, everything worked. It felt like a DNS issue, so I went back to my preferred network (my company’s internal network) and manually overrode the DNS server config and, boom, everything worked. I tried pinging the first DNS entry that was configured by DHCP and found that the server was down. I asked around and found out that it was down due to a power outage. What I find interesting is that Docker must be just grabbing the first DNS entry on the network connection and using it exclusively instead of going down the chain until it gets an answer. I’m far from being a network guy, so I’m sure I’m saying most of that incorrectly, but if anyone else is having a similar issue, check to see if the first DNS server entry is working.

Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160621-131411.tar.gz
failure: No error was detected
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux


DNS request timed out for index.docker.io during pull/push/search