SOLVED: Docker: Error response from daemon: grpc: the connection is unavailable

Hi all,

Anyone have any idea what’s causing this error? Is it going to be something to do with my network settings?

(bit of a noob on networking front, please feel free to comment and point me in the right direction for relevant data)

Get it when trying to do:

  • any docker run commands
  • any docker build with package updates (e.g RUN apk update)


  • Docker version 1.13.0, build 78d1802
  • openSUSE Tumbleweed 20170505

Testing issue

Tried running the following containers to no avail:

  • Redis:latest
  • alpine:latest
  • python:3.4.6
  • python:latest
  • hello-world


Docker service running fine - systemctrl status docker returns:

docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2017-05-17 16:21:18 BST; 2 days ago

From docker inspect, containers are exiting with:

  • Exitcode 128
  • "Error": "grpc: the connection is unavailable"

Running systemctl restart docker sorted it out

No idea why it happened in the first place though.