Docker Community Forums

Share and learn in the Docker community.

Starting Remote Desktop service does not listen on network port

Expected behavior

I can connect to the running Remote Desktop Services service in a container launched from a Windows Insider image.

Actual behavior

I cannot connect to the service from outside the container

Information

  • Base images is mcr.microsoft.com/windows/insider:10.0.17763.107_amd64
  • Dockerfile adds a registry key to enable a listener in the container

Steps to reproduce the behavior

  1. Build image from Dockerfile
  2. Launch image into a powershell process with docker run -it -p 3390:3389 termserver powershell
  3. Start TermService with Start-Service TermService
  4. Verify service is running with Get-Service TermService
  5. Inspect listening TCP ports with netstat -an

The last step should output all services listening on a port. TCP port 3389 (RDP default) should not appear in the output.

No response for that? I’m also trying to launch remote desktop connection, but no success so far.