Docker Community Forums

Share and learn in the Docker community.

Swarm mode is not working on Windows 10

I downloaded the latest docker engine 2.0.0.3 (31259) on my windows 10 machine. Then I wanted to try the swarm mode, so I created an Ubuntu VM using hyper-v, then I started the swarm mode on windows and tried to join the worker from ubuntu but I keep getting Connection refused.

I made sure all required ports tcp/udp are open on both the windows 10 and the ubuntu VM. But even when I try telnet on port 2377 it also fails.

I tried running “netstat -ab” command on the windows machine I do NOT see port 2377 listed.

To make sure problem is from docker, I created a windows app that listens on port 2377, and then i successfully connected to it from the Ubuntu machine. So port is not blocked by firewall.

I searched here and on the web and mostly found very old questions related to this.

I got the same issue.
Running following specs for my leader node:

Docker version 19.03.2, build 6a30dfc
Windows 10
Running Linux Containers

I can create a swarm but the listener on port 2377 is not showing under netstat.