Docker Community Forums

Share and learn in the Docker community.

Does Docker for Windows support swarm mode?

Hi,

I have two Windows 10 host, both have Docker for Windows installed. On machine A, I executed:

docker swarm init --advertise-addr my-host-ip

And it returns something like:

docker swarm join \
--token SWMTKN-1-661mot4yjt30vgxoz56pkcfr0b1nffephp6ekffuof9qoenym3-4cjnd23qq06wvhj9j9c53se1b \
my-host-ip:2377

Then I enabled port 2377 on my Windows firewall settings.

On machine B, I executed the about swarm join command, but I got timeout error, and docker info always says the swarm is inactive.

Both docker engine’s Network settings are using the default setting, which is 10.0.75.0. And the DockerNAT switch does not have port forward configuration. So I have no idea which IP I should use for the --advertise-addr option.

Thanks,
David

This post might have some pointers: https://stefanscherer.github.io/docker-swarm-mode-windows10/

Errr…that feature is not available on Windows 10 stable builds.

Important Note: Currently, swarm mode and overlay networking support are available only to Windows Insiders as part of the upcoming Windows 10, Creators Update. Support for further Windows platforms coming soon.

Thanks.

is this problem still on in 2019! … I am trying to start the swarm and i do get the success message. I made sure all required ports are enabled from windows firewall. But when I try to join a worker I get the message “connection refused”.
I checked using netstat command and the port 2377 is not listed as open, so it seems that the docker service is not really listening on the port.
I tried making a sample app which listens to port 2377, and I was able to connect to it using telnet from other machines.