The com.docker.service is not a win32 valid application

Hi to all, I have a problem during the Docker for Windows update to 17.06.2-ce version. During the installation the setup program stops.

Windows events log:

Docker for Windows Service non è un'applicazione di Win32 valida. ID Event : 7000

Docker log:

Version: 17.06.2-ce-win27 (13194)
Channel: stable
Sha1: 428bd6ceae2994bd2fc2a72ec122507abe2cf526
Started on: 2017/09/14 22:49:57.694
Resources: C:\Program Files\Docker\Docker\Resources
OS: Windows 10 Pro
Edition: Professional
Id: 1703
Build: 15063
BuildLabName: 15063.0.amd64fre.rs2_release.170317-1834
File: C:\Users\XXX\AppData\Local\Docker\log.txt
CommandLine: "C:\Program Files\Docker\Docker\Docker for Windows.exe" 
You can send feedback, including this log file, at
[22:49:59.631][GUI            ][Info   ] Starting...
[22:51:48.865][Tracking       ][Info   ] Crash report and usage statistics are enabled
[22:51:48.874][SegmentApi     ][Info   ] Usage statistic: appLaunched
[22:53:35.810][GUI            ][Error  ] Unable to start Docker for Windows service: 2
[22:54:06.135][ErrorReportWindow][Info   ] Open logs

Docker for Windows service command:

C:\Program Files\Docker\Docker\com.docker.service

I have already tried the installation 10/15 times.


Hi, Did you check the requirements listed here:

Hi, sorry, I forgot to say it is an upgrade from 17.06.1-ce, not a new installation.

I partially solved my problem, the solution to the error 7000 was to change the command of the service: C:\Program Files\Docker\Docker\com.docker.service, to: “C:\Program Files\Docker\Docker\com.docker.service”. I added the double quotes, now the services starts, but if I try again to install, the Docker for Windows installer recreate it without the ["] double quotes.