Docker Community Forums

Share and learn in the Docker community.

"The system cannot move the file to a different disk drive"


(Greenpj) #1

Hi,

I’ve installed

  • Windows Server 2016 Build 14393.rs1_release_inmarket.161102-0100
  • Installed all latest Windows Updates (shows KB3200970, KB3199986 and KB3192137 in Installed Updates)
  • Docker version 1.14.0-dev (also tried 12)

When I run the following;

docker - run microsoft/nanoserver cmd echo hello

I always get ;

docker: Error response from daemon: container d870cbd6d0142d6ca766feef4fb9de4b76129322cc131e7aff0addce3298443b encountered an error during CreateContainer: failure in a Windows system call: The system cannot move the file to a different disk drive. (0x11)

In fact this always happens no matter what container I have and no matter what command.

I’ve re-built the VM from scratch twice now just in case, but the same problems.

The only non-standard thing I can see about the host server is that it has an X: drive - not a C: drive. I can’t change this easily as the image is built by our devops guys and it’s some kind of standard they enforce (but even they don’t know why). I’m wondering if there’s some hard coding in there which assumes there’s a C: drive.

Many thanks in advance for any help.
Paul


(Bazzilic) #2

I have the same issue. Apparently, the issue is with the drive letter, as my installation of Windows Server is on drive E:/ and I see the same error.


(Mscrivo) #3

Is there no resolution for this? I have the same problem and unfortunately, cannot change the system drive letter in this case.