Docker Community Forums

Share and learn in the Docker community.

Trying to start Docker

for a C++ project image.

Check if you start docker service.

This is a WSL console. You have Docker running in Docker Desktop? Then Docker is not at /var/run/docker.sock but tcp://localhost:2375.

I have also encountered the same problem. Tried everything from giving dynamic memory to enabling and disabling Hyper V and many more. But with all that, I got no success.

Then I tried these steps for

Docker won’t start on Windows: Not Enough memory to start docker:

  1. From System Tray menu, right click on Docker icon

  2. Select Switch to Windows containers…

  3. Restart the system.

There you go after restarting your docker status should be showing as: Docker is running

Hope this helps!

PS: Switching back to Linux container should work now after switching to Windows Containers for most of the users as said by rfay.

I was not able to install Docker desktop since I only have Win 10 home version and not enterprise or pro.
I have a Docker only on the command line. I couldn’t find a tutorial for linking Docker daemon on Win 10 to the WSL.

This means Docker isn’t running anywhere on your system. What you call from WSL is only the Docker command line.
You can install Docker Desktop on Windows 10 Home if you are at version 2004 and your system meets some other requirements. Take a look at Install Docker Desktop on Windows Home.

Thanks. I’ll take a look at it.

Did you follow a specific guide?
A guide like this will get you setup and probably help in your case: https://nickjanetakis.com/blog/setting-up-docker-for-windows-and-wsl-to-work-flawlessly

I do not have docker-toolbox anymore as I moved to Windows PRO but I do remember running a docker-machine command. Can you run the following command:
docker-machine ip default
If you dont get something like 192.168.99.100 or an error that the d-machine is not running, I suggest (from the top of my head) docker-machine start or “restart”. You can try docker-machine help for reference.

I also suggest you start running a hello world for simplicity. As soon as you get the first container running, you are all set. Docker-toolbox as you know is meant for Windows Home. Nevertheless it should work. I used it like for a year.