Unable to create Organization (or logoff)

Running on Mac OS (Catalina) using any of Safari 13.0.4, Chrome 79.0.3945.88, or Brave 1.2.42 I am unable to logoff with out clearing all cookies and restarting the browser. This is annoying.

What is infurating is that I am unable to create an Organization. The popup wizard silently does nothing after hitting “create organization”, and the organization is not created. Looking at the javascript consoles, I can see various warnings that appear to be related to ad tracking resources being blocked. As far as I can determine from the traces I am seeing, the website just does not work properly if you have any privacy tools enabled. Disabling all privacy tools and trying again results in at least Chrome having a proper complain about dodgy queries, and the logoff/create organization still not working.

Please advise what browsers are compatible with your website (after you have a look at the calendar and see that it’s 2020 and this is not a question that should need to be raised)

Internet Exploreer 11.914.17763.0, and Microsoft Edge, do at least allow me to log off, but creating an organization still fails with a 400 for each of those browsers.

oh good grief. The organisation name was already taken? Try another organisation name and it worked. Why the hell was there no error message or feedback? Still cannot log off though.