Unable to delete my private repo

Hi there,
Yesterday I created a repo with slash dash in it’s name by mistake. I tried to delete it immediately, but I was unable.
I really dont know what is the issue with it.

A slash or a dash? I’m not seeing a slash anywhere in the screenshot but maybe that’s part of the issue?

How did you try to delete it, and did you get any error?

Ah you are right, I mean a dash.

I tried via the web interface, by going to the repo, then setting and delete.

No warning or errors at all.

Maybe it is related to tag deletion. I have only one image/tag pushed to that repo with the “latest” tag, but I cannot remove it. I cannot leave the repo empty.

Advises are welcomed.

You can leave a repo empty. I did it. In fact, when you create a new repo, that is empty too.

How have you tried to delete it? If you really want to delete a repo, then go to the repository’s settings and click “Delete Repository”

If you just deleted tags either from the terminal or from the browser, the repository will not be deleted, but you will not have any image in it


I realized that Arjan asked the same question and you have already answered…
But then I don’t understand why you wrote that you cannot leave a repo empty. Are you sure tried to delete a repo and not the tags?

Would you share a screenshot of the page where you try to delete the repo?

That was very odd…

I decided to test to make the repository public, then delete it. Guess what? It worked.
I was able to delete it ;-))) Don’t know what to say.